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What is a Database?


A database is simply a technical word for a collection of information that has been organized into a list. This is somewhat oversimplified, but whenever you use or make a list of information – names, addresses, products, customers or invoices – you are using a database. Microsoft Access is a database software program that runs on PCs and Macs and is used to manage data that can be organized into lists of related information.
Reasons for using a database

· Data entry is faster and easier;

· Information retrieval is faster and easier;

· Information can be viewed and sorted in many ways;

· Information is more secure;

· Information can be shared among several users;

· Duplicate data entry is minimised.

Planning

Although you can always make changes to your database when necessary, a little planning when you begin can save time later on. When you plan the database, consider how you will use the data. What kind of data are you collecting? What kind of data are you entering? How are the data values related to one another? Can your data be organised into separate, smaller groups? What kinds of safeguards can you create to ensure that errors do not creep into your data?

Tables

Tables are the fundamental building blocks of a database. Database planning begins with deciding how many and what kinds of tables your database will contain. You may want to organise your database information into several tables, each one containing fields related to a specific topic rather than one large table containing many different fields.

Terminology

· Field:
category of information;

· Key Field:
a field that contains unique information for each record.

· Record:
a group of related fields

· Table:
contains all of the raw data within the database in a spreadsheet-like view;

· Query:
provides a spreadsheet-like view of the data similar to tables, but a query can be designed to view a subset of fields and records.

· Form:
provides an easy-to-use data entry screen which generally shows only one record at a time.

· Report:
provides a professional printout of the data that can contain enhancements such as headers, footers and calculations
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Getting Going
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When you run Access for the first time, you will be prompted to save the database before you can begin to enter data. Create a folder and save your database in it with the name CD Collection or similar, as your first database will contain information about some music CDs. When you have saved the file, you will need to set up your first table with field names and field types for you to enter your information. Although there are several ways of doing this, by far the most flexible method is to create your table in Design View. Note the icon for Design View, as you will be using it quite a lot when creating your database. Double click the Create table in Design View icon to start creating the fields and setting the field types. It is very important to set the correct field (or data) type if you want the database to function correctly. The main types are as follows:

· Text:
textual information or a combination of text and numbers up to 255 characters in length;

· Memo:
text such as comments or notes up to 64,000 characters in length;

· Number:
numerical information with several formats and several degrees of accuracy;

· Date/Time:
dates and times with a range of formats;

· Currency:
for displaying numbers as monetary values;

· AutoNumber:
integers assigned by Access to sequentially order each record added to a table;

· Yes/No:
only one of two values stored – can also be On/Off, True/False;

· Lookup:
a limited range of choices created by you.
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Whichever data type you select for the field, Access provides a further range of choices for you to specify parameters for each type, for example the way dates are displayed, choices of currency etc. For this database, use the following list of field names and decide which data type would be the most appropriate: (Note: CDIndex should be set to AutoNumber)


CDIndex; CDTitle; Artist; Released; NoTracks; TotalDuration; Formats; RRP; Retailer

Note that each field name is entered without spaces; although this is not compulsory it is one of those unwritten rules of database construction. If you would like the field headings to be more informative, use the Caption entry in Field Properties to enter an alternative (displayed) heading. In a similar way, you don’t have to enter a field description, but it makes sense to enter an explanation of what each field represents. When you have entered all of the fields and set their properties, save the table by clicking the disc icon in the toolbar.
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Now change to Datasheet View to begin entering information into the database. Note that depending on your current view of the database, you can change view by clicking the View icon on the toolbar, or by selecting View from the Menu bar. The Datasheet view is similar to what you would see in a spreadsheet. Note: you will be asked to set one of the fields as a Primary Key – use a value which is unique to each record: CDIndex.

The Data
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The following is a list of the information to be entered. All the data was collected from websites that sell music CDs, in particular www.101cd.com. If you want to add more information, there are a number of websites that provide details on CDs such as www.amazon.co.uk , www.whsmith.co.uk and www.cdnow.com .

Start by entering the first CDIndex value, then press the Tab key on the keyboard to move to the next insert point. When you have finished entering all of the data, save the table by selecting the disc icon on the toolbar.

Editing the data and data display

You decide that you would like the date to be displayed with a full month. Change to Design View and alter the field properties accordingly.

You want to make it explicit how you would like the Total Duration values to be entered. Use the Input Mask feature of the Field Properties to display Long Time – hours:mins:secs or enter hh:nn:ss
Due to a sale, Tarkus is now £15.99, Fragile is £4.99 and Day at the Races is £8.99. Update the table.

After listening to Classic FM on the radio during your journey to and from school, you decide to buy some new classical CD recordings. Add the following data (or find some titles on the Internet and use those) then save the file.
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You decide that you would like to have another field that displays the Genre of the music with the following categories: Rock, Pop, Folk, Comedy, Classical. Switch to Design View and insert a new row after Artist. Set the Field Name to Genre and the Data Type as Lookup Wizard… In the dialogue box that opens, choose I will type in the values that I want then click Next>. On the next screen, enter the 5 choices in Col1 then click Next>. Check that the label for the lookup column is still Genre before clicking on Finish. Save the file and switch to Datasheet View to find that the new Field has a drop-down menu containing the five Genres; choose an appropriate Genre for each CD then save the file again.

What other field could benefit from having a drop-down list of pre-defined options? Set this up, but bear in mind whether you will limit the user to your list of choices or allow them to add their own information. Save your work.
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Formatting the Datasheet

At some point you will need to print out the datasheet. You may not like the default font, size, colour and gridline settings so there are some basic choice available to you prior to printing.

To change the font and style, you do not have to select or highlight any data. select all of the data. Simply use the standard formatting tools from the toolbar such as font name, size, bold, italic, colour, cell background colour and so on. Your settings will affect all the information in the Datasheet.

If you want to change the grid line settings, select Format>Datasheet from the menu. Your choices include whether or not to have vertical and horizontal lines and what 3D effects for each cell – sunken or raised.

Check your settings by selecting Print Preview from the File menu or the icon on the toolbar. By default, the page is set to Portrait format with rather wide margins. To change this, close the Print Preview window and choose Page Setup from the File menu. Check your settings in Print Preview again then save the file.
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Sorting Records
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At some point, you will need to sort the data into a logical order, perhaps by Artist name or duration. The Access toolbar provides you with two sort actions – Sort Ascending (A to Z) and Sort Descending (Z to A). To use, select a field to be sorted then click the appropriate Sort icon (ascending or descending). Note that you don’t have to highlight rows, columns or areas as each row is a complete database record.
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Obviously this method of sorting only allows a sort on one field. To do a sort on more than one field, you need to perform an advanced sort. This is available from Records>Filter>Advanced Filter/Sort… in the menu bar. When selected, a new, blank table is displayed into which you can drag the Field Names you want to sort into the top row. In the second row, you specify how you would like each field sorted. In the example shown, Artist is sorted in Ascending order and CDTitle is sorted Descending: To instigate the Sort, select the Apply Filter icon in the main toolbar – it looks like a small funnel: 

Applying the sort above, you should find the two David Bowie titles have been sorted correctly with Hunky Dory appearing above Aladdin Sane. Sort the records back to their original order – CDIndex: Ascending.

Using the sorting facilities, find out the following:

Which of the CDs has the earliest release date?

Which CD has the longest playing time?

Which CD has the greatest number of tracks?

Sort the CD collection into Genre Ascending and Artist Ascending. Which CD title is at the top of the list?

Filtering Records

Filter by Selection
When you need to display a subset of the records, you apply a filter. This is slightly different from running a search or query which suggests multiple, linked tables. Again, Access provides a quick way of filtering and a slightly more advanced method. The quickest way is to filter by selection, denoted by the icon that looks like a funnel with a bolt of lightning next to it! To make this work, select any occurrence of the word Rock in any record then click on the Filter by Selection icon. You should now only see the records that are in the Rock genre. To view all records again, click on the Remove Filter icon. Try this a few times to get used to its action – select any part of a record and only those records matching the selected item will be shown when Filter by Selection is used. Don’t forget to select the plain filter afterwards or you won’t see all of the records!

Filter by Form

The Filter by Form method allows you to display records that match criteria – rules or limiting conditions you set. When you select the Filter by Form icon, you will see a table containing just one empty row underneath the field headings. Select any cell along the row and a drop-down menu will be available from which you can choose any one item (based on the information contained in each field). As an example, choose Classical from the Genre field then activate the filter by selecting Activate Filter from the toolbar. You should now see only the records for all the classical albums; choose the Remove Filter icon (it’s the plain funnel icon again) to view all records.

To view all classical albums by composers (Artist) whose names begin with the letter B, select Classical from the Genre field and enter B* from the Artist field. Activate the filter to find the one Bartok album. To find all the classical albums by composers whose names contain the letter B, change the above filter to *B*. Activate the filter which should then display the CDs by Bach and Bartok. Note that the * character means any number of letters or numbers, whilst you can use ? to represent any single character.

How many CDs have less than 11 tracks? Enter <11 in the Track field.

How many albums are not available on Vinyl? Enter Not Vinyl in the Other Formats field.

Which albums were released after 1995? Enter >#31/12/95# in the Released field.

How many Pop and Rock albums were released in 1999? This is quite tricky! Enter In ("Pop","Rock") in the Genre field, then Between #31/12/98# And #01/01/00# in the Released field. Can you find an easier way of specifying 1999 in the Released field?

How many CDs have 10 or more tracks but cost less than £10? Of the CDs found, which has the best track number to price ratio? 

Stop Press!

You’ve had a small win on the lottery and decide to increase your CD collection from www.101cd.com. Add the following details:

When you have entered the details, save the file.




� EMBED MSDraw.Drawing.8.2  ���























� EMBED Excel.Sheet.8  ���





� EMBED Excel.Sheet.8  ���





� EMBED Excel.Sheet.8  ���








Introduction to MS Access
Page 4
©BITC 2002

_1075037240.xls
CD_Info

		CDIndex		CDTitle		Artist		Released		NoTracks		TotalDuration		Formats		RRP

		11		Brandenburg Concertos		J S Bach		11/1/00		19		2:10:54		Cassette		£27.99

		12		Requiem		W A Mozart		8/21/00		19		0:56:30		Vinyl		£6.99

		13		The Rite of Spring		I Stravinsky		4/12/94		15		1:12:00		Cassette		£12.99

		14		Concerto for Orchestra		B Bartok		6/1/99		9		1:11:06		Vinyl		£8.99
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_1076482971.xls
CD_Info

		CDIndex		CDTitle		Artist		Released		NoTracks		TotalDuration		Formats		RRP

		15		No Angel		Dido		1/29/01		12		0:52:00		Cassette		£10.99		www.101cd.com

		16		Swing When You're Winning		Robbie Williams		11/19/01		15		1:12:08		MiniDisc		£7.99		www.101cd.com

		17		Echoes		Pink Floyd		11/5/01		26		2:14:00		Vinyl		£12.99		www.101cd.com
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_1062225420.unknown

_1075029330.xls
CD data

		CDIndex		CDTitle		Artist		Released		NoTracks		TotalDuration		Formats		RRP

		1		Tarkus		Emerson, Lake & Palmer		9/20/99		7		0:38:56		Cassette		£21.99

		2		Ten Summoners Tales		Sting		11/16/98		13		0:48:39		MiniDisc		£9.99

		3		Fragile		Yes		9/5/94		9		0:41:10		Vinyl		£5.99

		4		Dark Side of the Moon		Pink Floyd		7/25/94		10		0:42:58		Vinyl		£7.99

		5		New Tricks		Bonzo Dog Doo-Dah Band		12/31/00		21		1:10:00		Vinyl		£13.99

		6		Hunky Dory		David Bowie		9/6/99		11		1:00:00		Cassette		£6.99

		7		Aladdin Sane		David Bowie		9/6/99		10		0:59:40		Vinyl		£7.99

		8		Day at the Races		Queen		9/27/93		10		0:52:39		Cassette		£9.99

		9		Welcome to the Pleasuredome		Frankie Goes to Hollywood		11/23/98		16		1:02:00		Vinyl		£9.84

		10		Now we are Six		Steeleye Span		12/31/93		10		0:51:54		Vinyl		£10.61






